Debugging the CKEditor configuration

Here are, roughly in the order you should try them, some tips that may help you debugging a CKEditor configuration when the editor don't show up in the edit area after you've installed it:

  1. Clear the cache:

    Remember to clear the cache after you've changed any setting that has something to do with wysiwyg. Not clearing the cache is probably the most common source for CKEditor not showing up as you would expect.

  2. Check out that roles are configured correctly:

    Navigate to your text formats: Administration » Configuration » Content authoring » Text formats and ensure the roles are configured correctly.

    Add the roles you want to use wysiwyg to Filtered HTML and Full HTML..

  3. Check out that profiles are set up right:

    Navigate to your ckeditor profiles: Home » Administration » Configuration » Content authoring » CKeditor.

    Go to the profiles, and verify that the text formats for the profile are set, and the editor appearance is set properly.

    • Under Basic Setup, check the text formats that apply.
    • Under Editor Appearance, set default state to enabled, and show the toggle.
  4. Check the paths:

    Navigate to Administration » Configuration » Content authoring » CKeditor » Global settings. Press Edit, and check that all the paths listed there actually exists.

  5. Check the default text processing option:

    Make sure that you've selected "Plain text" instead of "Filtered text" as your default text processing option. To change this, navigate to Administration » Structure » Content types, select the content you experience problems with and click manage fields and edit on the body field (and other text fields you want to use the wysywyg editor). Make sure that the preset text format for that text field is set to to one of the formats configured for wysywyg (e.g. Filtered HTML).

    To make sure that Filtered HTML is selectable, you need to make sure that the setting for "Text processing" is set to Filtered text (not Plain text):

    [screen dump]

    Press Save settings after changing this.

    Make sure that when you create content, a text format that is set up to use use wysiwyg (e.g. Filtered HTML) is selected. The screen dump below shows how the pull-down menu immediately below the text field for content should look like:

    [screen dump]

Problem not solved?

If none of the answers given to this question helps you, please create a comment and tell us what you've tried so far to solve your problem, and any details you can offer about your configuration.

Tags: